Atlassian Confluence Server 5.8.x < 5.8.6 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9645

Synopsis

The remote Confluence server is affected by multiple vulnerabilities.

Description

Versions of Confluence 5.8.x prior to 5.8.6 are affected by multiple vulnerabilities :

- A flaw exists that is triggered during the handling of disabled user accounts. This may allow a user with a disabled account still to receive unintended notifications that contain sensitive information.
- A flaw exists that allows a stored cross-site scripting (XSS) attack. This flaw exists because the comment module does not validate input when handling comments in embedded SWF files before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade to Confluence 5.8.x version 5.8.6 or later.

See Also

https://jira.atlassian.com/browse/CONF-38127

https://jira.atlassian.com/projects/CONF/versions/54995

Plugin Details

Severity: Medium

ID: 9645

Family: CGI

Published: 2016/10/14

Updated: 2019/03/06

Dependencies: 9543

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.1

Temporal Score: 5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Patch Publication Date: 2015/07/21

Vulnerability Publication Date: 2015/07/16