Atlassian Confluence Server 5.7.x < 5.7.6 Remote Disclosure

Medium Nessus Network Monitor Plugin ID 9644

Synopsis

The remote Confluence server is affected by a remote disclosure vulnerability.

Description

Versions of Confluence 5.7.x prior to 5.7.6 contain an insecure direct object reference flaw in the '/viewdefaultdecorator.action' script that is triggered when it does not properly restrict requests for files passed via the 'decoratorName' parameter. This may allow an authenticated remote attacker to gain access to read configuration files.

Solution

Upgrade to Confluence 5.7.x version 5.7.6 or later.

See Also

https://jira.atlassian.com/browse/CONF-39704

Plugin Details

Severity: Medium

ID: 9644

Family: CGI

Published: 2016/10/14

Updated: 2019/03/06

Dependencies: 9543

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 4.2

Temporal Score: 4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Patch Publication Date: 2015/11/19

Vulnerability Publication Date: 2016/01/04

Reference Information

CVE: CVE-2015-8399

BID: 79819