Atlassian Confluence Server 5.4.x < 5.4.2 XSS

Medium Nessus Network Monitor Plugin ID 9641

Synopsis

The remote Confluence server is affected by a stored cross-site scripting (XSS) vulnerability.

Description

Versions of Confluence 5.4.x prior to 5.4.2 contain a flaw that allows a stored XSS attack. This flaw exists because the 'Share a link' feature does not validate input to topics in a new dialog before returning it to users. This may allow an authenticated remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade to Confluence 5.4.x version 5.4.2 or later.

See Also

https://jira.atlassian.com/browse/CONF-31893

https://jira.atlassian.com/projects/CONF/versions/37691

https://jira.atlassian.com/projects/CONF/versions/37811

Plugin Details

Severity: Medium

ID: 9641

Family: CGI

Published: 2016/10/14

Updated: 2019/03/06

Dependencies: 9543

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 4.2

Temporal Score: 4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Patch Publication Date: 2014/01/13

Vulnerability Publication Date: 2014/01/28