Atlassian Confluence Server 5.1.x < 5.1.1 XSS

Medium Nessus Network Monitor Plugin ID 9637


The remote Confluence server is affected by a cross-site scripting (XSS) vulnerability.


Versions of Confluence 5.1.x prior to 5.1.1 contain a flaw that allows a reflected XSS attack. This flaw exists because the 'managereferrers.vm' script does not validate input to the 'justAdded' parameter before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.


Upgrade to Confluence 5.1.x version 5.1.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 9637

Family: CGI

Published: 2016/10/14

Updated: 2019/03/06

Dependencies: 9543

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 3.6

Temporal Score: 3.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Patch Publication Date: 2013/04/11

Vulnerability Publication Date: 2013/04/29