Atlassian Confluence Server 4.3.x < 4.3.6 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9636

Synopsis

The remote Confluence server is affected by multiple vulnerabilities.

Description

Versions of Confluence 4.3.x prior to 4.3.6 are affected by multiple vulnerabilities :

- A flaw exists that allows a stored cross-site scripting (XSS) attack. This flaw exists because the import word document functionality does not validate input when handling the title field before returning it to users. This may allow an authenticated remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 123806)
- A flaw exists as HTTP requests do not require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. By tricking a user into following a specially crafted link, a context-dependent attacker can perform a Cross-Site Request Forgery (CSRF / XSRF) attack causing the victim to edit pages, move pages, and create pages. (OSVDB 124929)

Solution

Upgrade to Confluence 4.3.x version 4.3.6 or later.

See Also

https://jira.atlassian.com/browse/CONF-26221

Plugin Details

Severity: Medium

ID: 9636

File Name: 9636.prm

Family: CGI

Published: 2016/10/14

Modified: 2016/11/23

Dependencies: 9543

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 4.2

Temporal Score: 4

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Patch Publication Date: 2013/01/14

Vulnerability Publication Date: 2013/01/16