Atlassian Confluence Server 4.3.x < 4.3.3 SQLi

High Nessus Network Monitor Plugin ID 9635


The remote Confluence server is affected by an SQL injection vulnerability.


Versions of Confluence 4.3.x prior to 4.3.3 contain a flaw that may allow carrying out an SQL injection attack. The issue is due to the 'deleteReferrersWithPrefix' method in the 'DefaultReferralManager' class in '' not properly sanitizing user-supplied input before using it in SQL queries. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.


Upgrade to Confluence 4.3.x version 4.3.3 or later.

See Also

Plugin Details

Severity: High

ID: 9635

Family: CGI

Published: 2016/10/14

Updated: 2019/03/06

Dependencies: 9543

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Patch Publication Date: 2015/07/23

Vulnerability Publication Date: 2013/01/29