phpMyAdmin 4.6.x < 4.6.3 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 9537
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server contains a version of phpMyAdmin that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin 4.6.x prior to 4.6.3 are unpatched, and therefore affected by the following vulnerabilities :

- A flaw exists in the Partition Range functionality that allows a cross-site scripting (XSS) attack. This flaw exists because the 'templates/table/structure/display_partitions.phtml' script does not validate input when handling table parameters before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists that allows an XSS attack. This flaw exists because the 'templates/table/structure/display_table_stats.phtml' script does not validate input when handling table comments before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists which may allow a context-dependent attacker to inject arbitrary values into browser cookies. No further details have been provided by the vendor. Note that this vulnerability is not present on a server configured to set 'PHP_SELF'.

Solution

Upgrade to phpMyAdmin version 4.6.3 or later.

See Also

https://www.phpmyadmin.net/news/2016/6/23/phpmyadmin-401016-44157-and-463-are-released

https://www.phpmyadmin.net/security/PMASA-2016-17

https://www.phpmyadmin.net/security/PMASA-2016-18

https://www.phpmyadmin.net/security/PMASA-2016-19

https://www.phpmyadmin.net/security/PMASA-2016-20

https://www.phpmyadmin.net/security/PMASA-2016-21

https://www.phpmyadmin.net/security/PMASA-2016-22

https://www.phpmyadmin.net/security/PMASA-2016-23

https://www.phpmyadmin.net/security/PMASA-2016-24

https://www.phpmyadmin.net/security/PMASA-2016-25

https://www.phpmyadmin.net/security/PMASA-2016-26

https://www.phpmyadmin.net/security/PMASA-2016-27

https://www.phpmyadmin.net/security/PMASA-2016-28

Plugin Details

Severity: Medium

ID: 9537

Family: CGI

Published: 8/30/2016

Updated: 3/6/2019

Dependencies: 9102

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*

Patch Publication Date: 6/23/2016

Vulnerability Publication Date: 6/23/2016

Reference Information

CVE: CVE-2016-5702, CVE-2016-5704, CVE-2016-5732

BID: 91380, 91386, 91392