phpMyAdmin 4.4.15.x < 4.4.15.7 / 4.6.x < 4.6.3 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 9536
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server contains a version of phpMyAdmin that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin 4.4.15.x prior to 4.4.15.7, and 4.6.x prior to 4.6.3 are unpatched, and therefore affected by the following vulnerabilities :

- A flaw exists that may allow carrying out an SQL injection attack. The issue is due to the 'libraries/central_columns.lib.php' script not properly sanitizing user-supplied input when handling database names. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data. Note that exploitation requires the existence of a controluser configured in config.inc.php.
- A flaw exists that allows a cross-site scripting (XSS) attack. This flaw exists because the 'libraries/server_privileges.lib.php' script does not validate input to the 'ssl_cipher', 'x509_issuer', or 'x509_subject' parameters before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists that allows a reflected XSS attack. This flaw exists because the 'js/console.js' script does not validate input to server error messages before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists that allows attack. This flaw exists because the 'js/functions.js' script does not validate input to database names before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists that allows attack. This flaw exists because the 'libraries/server_privileges.lib.php' script does not validate input to user groups before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists that allows attack. This flaw exists because the 'libraries/DBQbe.class.php' script does not validate input to saved search names before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade to phpMyAdmin version 4.6.3 or later. If 4.6.3 cannot be obtained, version 4.4.15.7 has also been patched for these vulnerabilities.

See Also

https://www.phpmyadmin.net/news/2016/6/23/phpmyadmin-401016-44157-and-463-are-released

https://www.phpmyadmin.net/security/PMASA-2016-17

https://www.phpmyadmin.net/security/PMASA-2016-18

https://www.phpmyadmin.net/security/PMASA-2016-19

https://www.phpmyadmin.net/security/PMASA-2016-20

https://www.phpmyadmin.net/security/PMASA-2016-21

https://www.phpmyadmin.net/security/PMASA-2016-22

https://www.phpmyadmin.net/security/PMASA-2016-23

https://www.phpmyadmin.net/security/PMASA-2016-24

https://www.phpmyadmin.net/security/PMASA-2016-25

https://www.phpmyadmin.net/security/PMASA-2016-26

https://www.phpmyadmin.net/security/PMASA-2016-27

https://www.phpmyadmin.net/security/PMASA-2016-28

Plugin Details

Severity: Medium

ID: 9536

Family: CGI

Published: 8/30/2016

Updated: 3/6/2019

Dependencies: 9102

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*

Patch Publication Date: 6/23/2016

Vulnerability Publication Date: 6/23/2016

Reference Information

CVE: CVE-2016-5703, CVE-2016-5705

BID: 91378, 91381