Moodle 2.5.x < 2.5.5 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9423

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.5.x prior to 2.5.5 are exposed to the following vulnerabilities :

- A flaw exists in the 'mod/chat/chat_ajax.php' script that is due to the program checking capabilities at the start of a chat and not during a chat. This will cause changes to not be enforced immediately. (CVE-2014-0122)
- A flaw exists that is due to the program failing to perform access checks on certain wiki pages. This may allow an unauthorized remote attacker to gain access to potentially sensitive information from other user's individual wikis via the recent activity block. (CVE-2014-0123)
- A flaw exists in the 'mod/forum/renderer.php' script that is due to Forum exposing user's email addresses regardless of security settings. This may allow an authenticated remote attacker to gain access to email information. (CVE-2014-0124)
- A flaw exists that is triggered when handling alias links to items in an Alfresco repository. This may allow a remote attacker to gain access to session key information and subsequently impersonate a file owner. (CVE-2014-0125)
- A flaw exists as HTTP requests to 'enrol/imsenterprise/importnow.php' do not require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. By tricking a user into following a specially crafted link, a context-dependent attacker can perform a Cross-Site Request Forgery (CSRF / XSRF) attack causing the victim to import IMS Enterprise identities. (CVE-2014-0126)
- A flaw exists in 'mod_feedback' that is due to the program failing to restrict a user from starting a Feedback activity while Feedback supposed to be closed. This may allow a remote attacker to bypass restrictions on Feedback Availability. (CVE-2014-0127)
- A flaw exists in 'badges/mybadges.php' that is due to the program failing to restrict users from toggling the visibility of other user's badges. This may allow a remote authenticated attacker to change a user's badge visibility. (CVE-2014-0129)
- A flaw exists that allows a cross-site scripting (XSS) attack. This flaw exists because the 'quiz_question_tostring()' function in the 'mod/quiz/editlib.php' script does not validate input before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between the browser and the server. (CVE-2014-2571)

Solution

Upgrade to Moodle version 2.5.5 or later.

See Also

https://docs.moodle.org/dev/Moodle_2.5.5_release_notes

Plugin Details

Severity: Medium

ID: 9423

File Name: 9423.prm

Family: CGI

Published: 2016/07/21

Modified: 2016/11/23

Dependencies: 8690

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2014/03/10

Vulnerability Publication Date: 2014/03/17

Reference Information

CVE: CVE-2014-0122, CVE-2014-0123, CVE-2014-0124, CVE-2014-0125, CVE-2014-0126, CVE-2014-0127, CVE-2014-0129, CVE-2014-2571

BID: 66326, 66330, 66331, 66332, 66334, 66335, 66337, 66450