Moodle 2.3.x < 2.3.2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9409

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.3.x prior to 2.3.2 are exposed to the following vulnerabilities :

- A flaw exists that may allow a remote attacker to manipulate parameters for the 'repository/repository_ajax.php script'. This will allow the attacker to bypass restrictions and upload a file that is larger than the allotted size. (CVE-2012-4400)
- A flaw exists that is triggered when the application fails to properly restrict access to certain topic functions. This may allow a remote attacker to show or hide topics, as well as set a current topic. (CVE-2012-4401)
- A flaw exists that is triggered when the 'webservice/lib.php' script fails to properly limit tokens to the service that issued them. This may allow a remote attacker to use a token intended for one service to gain access to arbitrary other external services. (CVE-2012-4402)
- A flaw exists that may lead to an unauthorized information disclosure. The issue is triggered when a remote attacker creates a malformed request for the 'yui_combo.php' script, which discloses the software's installation path resulting in a loss of confidentiality. While such information is relatively low risk, it is often useful in carrying out additional, more focused attacks. (CVE-2012-4403)
- A flaw exists that may lead to an unauthorized information disclosure. The issue is triggered when the 'lib/filelib.php' script does not properly check the publication state of blog files. This may allow a remote attacker to gain access to the embedded files of the blog before it is published. (CVE-2012-4407)
- A flaw exists when permissions are not properly verified on the reset page. This may allow a remote attacker to reset a course via the reset page. (CVE-2012-4408)

Solution

Upgrade to Moodle version 2.3.2 or later.

See Also

https://docs.moodle.org/dev/Moodle_2.3.2_release_notes

Plugin Details

Severity: Medium

ID: 9409

File Name: 9409.prm

Family: CGI

Published: 2016/07/21

Modified: 2016/07/21

Dependencies: 8690

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.4

Temporal Score: 5.2

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2012/09/17

Vulnerability Publication Date: 2012/09/17

Reference Information

CVE: CVE-2012-4400, CVE-2012-4401, CVE-2012-4402, CVE-2012-4403, CVE-2012-4407, CVE-2012-4408

BID: 55565