phpMyAdmin 4.0.x < 220.127.116.11 / 4.4.x < 18.104.22.168 / 4.5.x < 22.214.171.124 Multiple XSS (PMASA-2016-11)
Medium Nessus Network Monitor Plugin ID 9356
SynopsisThe remote web server contains a PHP application that is affected by multiple cross-site scripting vulnerabilities.
DescriptionVersions of phpMyAdmin 4.0.x prior to 126.96.36.199, 4.4.x prior to 188.8.131.52, or 4.5.x prior to 184.108.40.206 are unpatched for multiple cross-site scripting (XSS) vulnerabilities. These attacks may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
The following phpMyAdmin components are affected by these vulnerabilities :
- A flaw which exists because the 'User Accounts' page does not validate input before returning it to users. (OSVDB 135205)
- A flaw which exists because the 'Zoom Search' page does not validate input before returning it to users. (OSVDB 135206)
- A flaw which exists because the program does not validate input when handling URLs sent in the HOST header before returning it to users. (OSVDB 135207)
- A flaw which exists because the program does not validate unspecified input when handling URLs before returning it to users. (OSVDB 135208)
SolutionUpgrade to phpMyAdmin 220.127.116.11 or later. Alternatively, apply the patch referenced in the vendor advisory. If version 18.104.22.168 cannot be installed, versions 22.214.171.124 and 126.96.36.199 are also patched for these vulnerabilities.