phpMyAdmin 4.0.x < 4.0.10.15 / 4.4.x < 4.4.15.5 / 4.5.x < 4.5.5.1 Multiple XSS (PMASA-2016-11)

Medium Nessus Network Monitor Plugin ID 9356

Synopsis

The remote web server contains a PHP application that is affected by multiple cross-site scripting vulnerabilities.

Description

Versions of phpMyAdmin 4.0.x prior to 4.0.10.15, 4.4.x prior to 4.4.15.5, or 4.5.x prior to 4.5.5.1 are unpatched for multiple cross-site scripting (XSS) vulnerabilities. These attacks may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

The following phpMyAdmin components are affected by these vulnerabilities :
- A flaw which exists because the 'User Accounts' page does not validate input before returning it to users. (OSVDB 135205)
- A flaw which exists because the 'Zoom Search' page does not validate input before returning it to users. (OSVDB 135206)
- A flaw which exists because the program does not validate input when handling URLs sent in the HOST header before returning it to users. (OSVDB 135207)
- A flaw which exists because the program does not validate unspecified input when handling URLs before returning it to users. (OSVDB 135208)

Solution

Upgrade to phpMyAdmin 4.5.5.1 or later. Alternatively, apply the patch referenced in the vendor advisory. If version 4.5.5.1 cannot be installed, versions 4.4.15.5 and 4.0.10.15 are also patched for these vulnerabilities.

See Also

https://www.phpmyadmin.net/security

https://www.phpmyadmin.net/security/PMASA-2016-11

Plugin Details

Severity: Medium

ID: 9356

Family: CGI

Published: 2016/06/17

Modified: 2016/06/17

Dependencies: 9102

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 3.6

Temporal Score: 3.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2016/02/25

Vulnerability Publication Date: 2016/02/25

Reference Information

CVE: CVE-2016-2560