phpMyAdmin 4.5.x < 22.214.171.124 Multiple Vulnerabilities (PMASA-2016-10, PMASA-2016-13)
Medium Nessus Network Monitor Plugin ID 9355
SynopsisThe remote web server contains a PHP application that is affected by multiple vulnerabilities.
DescriptionVersions of phpMyAdmin 4.5.x prior to 126.96.36.199 are unpatched for the following vulnerabilities :
- A flaw exists that allows a cross-site scripting (XSS) attack. This flaw exists because the SQL query page does not validate input when handling a crafted SQL query before returning it to users. This may allow an authenticated remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (CVE-2016-2559)
- An unspecified flaw exists within the API call to Github that may allow a remote attacker to perform a man-in-the-middle attack. No further details have been provided. (CVE-2016-2562)
SolutionUpgrade to phpMyAdmin 188.8.131.52 or later. Alternatively, apply the patch referenced in the vendor advisory.