phpMyAdmin 4.5.x < 4.5.5.1 Multiple Vulnerabilities (PMASA-2016-10, PMASA-2016-13)

Medium Nessus Network Monitor Plugin ID 9355

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin 4.5.x prior to 4.5.5.1 are unpatched for the following vulnerabilities :

- A flaw exists that allows a cross-site scripting (XSS) attack. This flaw exists because the SQL query page does not validate input when handling a crafted SQL query before returning it to users. This may allow an authenticated remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (CVE-2016-2559)
- An unspecified flaw exists within the API call to Github that may allow a remote attacker to perform a man-in-the-middle attack. No further details have been provided. (CVE-2016-2562)

Solution

Upgrade to phpMyAdmin 4.5.5.1 or later. Alternatively, apply the patch referenced in the vendor advisory.

See Also

https://www.phpmyadmin.net/security

https://www.phpmyadmin.net/security/PMASA-2016-10

https://www.phpmyadmin.net/security/PMASA-2016-13

Plugin Details

Severity: Medium

ID: 9355

Family: CGI

Published: 2016/06/17

Modified: 2016/06/17

Dependencies: 9102

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 6.8

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2016/02/25

Vulnerability Publication Date: 2016/02/25

Reference Information

CVE: CVE-2016-2559, CVE-2016-2562