Apache ActiveMQ 5.x < 5.13.2 Clickjacking

Low Nessus Network Monitor Plugin ID 9318

Synopsis

The remote host is running a web application that is affected by a clickjacking attack vector.

Description

Versions of Apache ActiveMQ 5.x prior to 5.13.2 are affected by a flaw that is due to missing 'X-Frame-Options' headers in HTTP responses. This may potentially allow a context-dependent attacker to conduct a clickjacking attack.

Solution

Upgrade to ActiveMQ 5.13.2 or later.

See Also

http://activemq.apache.org/security-advisories.data/CVE-2016-0734-announcement.txt

Plugin Details

Severity: Low

ID: 9318

Family: CGI

Published: 2016/05/24

Modified: 2018/09/16

Dependencies: 8957

Nessus ID: 90025, 90026

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 3.7

Temporal Score: 3.6

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:activemq

Patch Publication Date: 2015/03/10

Vulnerability Publication Date: 2015/03/10

Reference Information

CVE: CVE-2016-0734