OpenSSH < 6.9 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9308

Synopsis

The remote SSH server may be affected by multiple vulnerabilities.

Description

Versions of OpenSSH server before 6.9 are affected by the following vulnerabilities :

- A flaw within the 'x11_open_helper()' function in the 'channels.c' file that allows connections to be permitted after 'ForwardX11Timeout' has expired. A remote attacker can exploit this to bypass timeout checks and XSECURITY restrictions. (CVE-2015-5352)
- Various issues were addressed by fixing the weakness in agent locking by increasing the failure delay, storing the salted hash of the password, and using a timing-safe comparison function.
- An out-of-bounds read error exists when handling incorrect pattern lengths. A remote attacker can exploit this to cause a denial of service or disclose sensitive information in the memory.
- An out-of-bounds read error exists when parsing the 'EscapeChar' configuration option.

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.

Solution

Upgrade to OpenSSH version 6.9 or later.

See Also

http://www.openssh.com/txt/release-6.9

Plugin Details

Severity: High

ID: 9308

Family: SSH

Published: 2016/04/22

Modified: 2018/09/16

Dependencies: 1997

Nessus ID: 84638

Risk Information

Risk Factor: High

CVSSv2

Base Score: 8.5

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.5

Temporal Score: 7.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Patch Publication Date: 2015/06/30

Vulnerability Publication Date: 2015/07/01

Reference Information

CVE: CVE-2015-5352

BID: 75525