Drupal 7.x < 7.43 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9220


The remote server is hosting an outdated installation of Drupal that is vulnerable to multiple attack vectors.


The remote server is hosting an outdated version of Drupal, a PHP-based open-source content management system. The version of Drupal installed on the remote server is 7.x prior to 7.43, and is affected by the following vulnerabilities :

- A flaw exists in the 'File' module that allows an attacker to view, delete, or substitute a link to a file that has not yet been submitted or processed by a form. An authenticated, remote attacker can exploit this, via continuous deletion of temporary files, to block all file uploads to a site. (OSVDB 135014)
- A flaw exists in the 'XML-RPC' system due to a failure to limit the number of simultaneous calls being made to the same method. A remote attacker can exploit this to facilitate brute-force attacks. (OSVDB 135015)
- A cross-site redirection vulnerability exists due to improper validation of unspecified input before returning it to the user, which can allow the current path to be filled-in with an external URL. A remote attacker can exploit this, via a crafted link, to redirect a user to a malicious web page of the attacker's choosing that targets weaknesses in the client-side software or is used for phishing attacks. (OSVDB 135016)
- An unspecified reflected file download flaw exists that allows an attacker to trick a user into downloading and running a file with arbitrary JSON-encoded content. (OSVDB 135020)
- A flaw exists, related to how the 'user_save()' API is utilized, due to assigning improper roles when saving user accounts. An authenticated, remote attacker can exploit this, via crafted data added to a form or array, to gain elevated privileges. (OSVDB 135021)
- An information disclosure vulnerability exists in the 'have you forgotten your password' due to displaying the username when a valid email address is provided. A remote attacker can exploit this to obtain the usernames recognized by the system. (OSVDB 135022)


Upgrade to Drupal 7.43, or later.

See Also




Plugin Details

Severity: Medium

ID: 9220

File Name: 9220.prm

Family: CGI

Published: 2016/04/08

Modified: 2016/04/08

Dependencies: 9211

Nessus ID: 89683

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 6.2

Temporal Score: 5.4


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2016/02/24

Vulnerability Publication Date: 2016/02/24

Reference Information

IAVA: 2015-A-0055