Drupal 7.x < 7.43 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 9220
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote server is hosting an outdated installation of Drupal that is vulnerable to multiple attack vectors.

Description

The remote server is hosting an outdated version of Drupal, a PHP-based open-source content management system. The version of Drupal installed on the remote server is 7.x prior to 7.43, and is affected by the following vulnerabilities :

- A flaw exists in the 'File' module that allows an attacker to view, delete, or substitute a link to a file that has not yet been submitted or processed by a form. An authenticated, remote attacker can exploit this, via continuous deletion of temporary files, to block all file uploads to a site.
- A flaw exists in the 'XML-RPC' system due to a failure to limit the number of simultaneous calls being made to the same method. A remote attacker can exploit this to facilitate brute-force attacks.
- A cross-site redirection vulnerability exists due to improper validation of unspecified input before returning it to the user, which can allow the current path to be filled-in with an external URL. A remote attacker can exploit this, via a crafted link, to redirect a user to a malicious web page of the attacker's choosing that targets weaknesses in the client-side software or is used for phishing attacks.
- An unspecified reflected file download flaw exists that allows an attacker to trick a user into downloading and running a file with arbitrary JSON-encoded content.
- A flaw exists, related to how the 'user_save()' API is utilized, due to assigning improper roles when saving user accounts. An authenticated, remote attacker can exploit this, via crafted data added to a form or array, to gain elevated privileges.
- An information disclosure vulnerability exists in the 'have you forgotten your password' due to displaying the username when a valid email address is provided. A remote attacker can exploit this to obtain the usernames recognized by the system.

Solution

Upgrade to Drupal 7.43, or later.

See Also

https://www.drupal.org/security

https://www.drupal.org/SA-CORE-2016-001

https://www.drupal.org/drupal-7.43-release-notes

Plugin Details

Severity: Medium

ID: 9220

Family: CGI

Published: 4/8/2016

Updated: 3/6/2019

Dependencies: 9211

Nessus ID: 89683

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*

Patch Publication Date: 2/24/2016

Vulnerability Publication Date: 2/24/2016

Reference Information

IAVA: 2015-A-0055