Drupal 7.x < 7.38 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9217

Synopsis

The remote server is hosting an outdated installation of Drupal that is vulnerable to multiple attack vectors.

Description

The remote server is hosting an outdated version of Drupal, a PHP-based open-source content management system. The version of Drupal installed on the remote server is 7.x prior to 7.38, and is affected by the following vulnerabilities :

- An open redirect vulnerability exists due to improper validation of user-supplied input to the 'destinations' parameter in the Field UI module. A remote attacker can exploit this issue, via a specially crafted URL, to redirect users to a third-party website. (CVE-2015-3231)
- An open redirect vulnerability exists due to improper validation of URLs prior displaying their contents via the Overlay module on administrative pages. (CVE-2015-3232)
- An information disclosure vulnerability exists due to a flaw in the render cache system. An attacker can exploit this flaw to view private content of arbitrary users. (CVE-2015-3233)
- A security bypass vulnerability exists due to a flaw in the OpenID module. A remote attacker can exploit this flaw to log in as other users, including administrators. Note that victims must have an existing OpenID account from a particular set of OpenID providers including, but not limited to, Verisign, LiveJournal, or StackExchange. (CVE-2015-3234)

Solution

Upgrade to Drupal 7.38, or later.

See Also

https://www.drupal.org/SA-CORE-2015-002

https://www.drupal.org/drupal-7.38-release-notes

https://www.drupal.org/security

Plugin Details

Severity: Medium

ID: 9217

Family: CGI

Published: 2016/04/08

Modified: 2016/04/08

Dependencies: 9211

Nessus ID: 84292

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.3

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2015/06/17

Vulnerability Publication Date: 2015/06/17

Reference Information

CVE: CVE-2015-3231, CVE-2015-3232, CVE-2015-3233, CVE-2015-3234

BID: 75284, 75286, 75287, 75294