Drupal 6.x < 6.37 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9215


The remote server is hosting an outdated installation of Drupal that is vulnerable to multiple attack vectors.


The remote server is hosting an outdated version of Drupal, a PHP-based open-source content management system. The version of Drupal installed on the remote server is 6.x prior to 6.37, and is affected by the following vulnerabilities :

- A cross-site scripting (XSS) vulnerability exists in the autocomplete functionality due to improper validation of input passed via requested URLs. An authenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code. (CVE-2015-6658)
- A cross-site request forgery (CSRF) vulnerability exists in the form API due to improper validation of form tokens. An authenticated, remote attacker can exploit this, via a specially crafted link, to upload arbitrary files under another user's account. (CVE-2015-6660)
- An information disclosure vulnerability exists that allows a remote, authenticated user to view the titles of nodes that they do not have access to. (CVE-2015-6661)


Upgrade to Drupal 6.37, or later.

See Also




Plugin Details

Severity: Medium

ID: 9215

File Name: 9215.prm

Family: CGI

Published: 2016/04/08

Modified: 2016/04/08

Dependencies: 9210

Nessus ID: 85652

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.6

Temporal Score: 5.3


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2015/08/19

Vulnerability Publication Date: 2015/08/19

Reference Information

CVE: CVE-2015-6658, CVE-2015-6660, CVE-2015-6661