Drupal 6.x < 6.36 OpenID Security Bypass

Medium Nessus Network Monitor Plugin ID 9214

Synopsis

The remote web server is hosting an outdated installation of Drupal that is vulnerable to multiple attack vectors.

Description

The remote web server is running a version of Drupal that is 6.x prior to 6.36. It is, therefore, potentially affected by a security bypass vulnerability due to a flaw in the OpenID module. A remote attacker can exploit this flaw to log in as other users, including administrators. Note that victims must have an existing OpenID account from a particular set of OpenID providers including, but not limited to, Verisign, LiveJournal, or StackExchange.

Solution

Upgrade to Drupal 6.36, or later.

See Also

https://www.drupal.org/SA-CORE-2015-002

https://www.drupal.org/drupal-6.36-release-notes

https://www.drupal.org/security

Plugin Details

Severity: Medium

ID: 9214

Family: CGI

Published: 2016/04/08

Modified: 2016/04/08

Dependencies: 9210

Nessus ID: 84291

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.3

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2015/06/17

Vulnerability Publication Date: 2015/06/17

Reference Information

CVE: CVE-2015-3234

BID: 75294