Drupal 6.x < 6.35 / 7.x < 7.35 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9213

Synopsis

The remote web server is hosting an outdated installation of Drupal that is vulnerable to multiple attack vectors.

Description

The remote web server is hosting an outdated version of Drupal, a PHP-based open-source content management system. The version of Drupal installed on the remote server is 6.x prior to 6.35 or 7.x prior to 7.35, and is affected by the following vulnerabilities :

- An access bypass vulnerability exists in which password reset URLs can be forged. This allows a remote attacker to gain access to another user's account. (CVE-2015-2559)
- An open redirect vulnerability exists which allows a remote attacker to craft a URL using the 'destination' parameter in order to trick users into being redirected to third-party sites. Additionally, several URL related API functions can be tricked into passing external URLs. (CVE-2015-2749, CVE-2015-2750)

Solution

Upgrade to Drupal 7.35, or later. If 7.x cannot be obtained, 6.35 is also patched for these vulnerabilities.

See Also

https://www.drupal.org/SA-CORE-2015-001

https://www.drupal.org/drupal-7.35-release-notes

https://www.drupal.org/drupal-6.35-release-notes

https://www.drupal.org/security

Plugin Details

Severity: Medium

ID: 9213

Family: CGI

Published: 2016/04/08

Modified: 2016/04/08

Dependencies: 9210, 9211

Nessus ID: 81975

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2015/03/18

Vulnerability Publication Date: 2015/03/18

Reference Information

CVE: CVE-2015-2559, CVE-2015-2749, CVE-2015-2750

BID: 73219