Moodle 2.8.x < 2.8.11 / 2.9.x < 2.9.5 / 3.0.x < 3.0.3 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9193

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

Moodle, an open-source course management system, installed on the remote host is version 2.8.x prior to 2.8.11, or 2.9.x prior to 2.9.5, or 3.0.x prior to 3.0.3, and is affected by multiple vulnerabilities :

- A flaw exists in the 'admin/tool/monitor/lib.php' script. This may allow an authenticated, remote attacker to disclose the names of hidden courses. (CVE-2016-2154)
- A flaw exists in Single View grade report related to improper capability checks. This may allow an authenticated, remote attacker to edit exclude checkbox in Single View. (CVE-2016-2155)

Solution

Upgrade to Moodle version 3.0.3 or later. If 3.0.x cannot be obtained, versions 2.9.5 or 2.8.11 have also been patched for these issues.

See Also

https://docs.moodle.org/dev/Moodle_2.8.11_release_notes

https://docs.moodle.org/dev/Moodle_2.9.5_release_notes

https://docs.moodle.org/dev/Moodle_3.0.3_release_notes

Plugin Details

Severity: Medium

ID: 9193

Family: CGI

Published: 2016/04/08

Modified: 2016/07/21

Dependencies: 8690, 9398

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.3

Temporal Score: 4

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2016/03/07

Vulnerability Publication Date: 2016/03/07

Reference Information

CVE: CVE-2016-2154, CVE-2016-2155