Moodle 2.8.x < 2.8.11 / 2.9.x < 2.9.5 / 3.0.x < 3.0.3 Multiple Vulnerabilities
Medium Nessus Network Monitor Plugin ID 9193
SynopsisThe remote web server is hosting a web application that is vulnerable to multiple attack vectors.
DescriptionMoodle, an open-source course management system, installed on the remote host is version 2.8.x prior to 2.8.11, or 2.9.x prior to 2.9.5, or 3.0.x prior to 3.0.3, and is affected by multiple vulnerabilities :
- A flaw exists in the 'admin/tool/monitor/lib.php' script. This may allow an authenticated, remote attacker to disclose the names of hidden courses. (CVE-2016-2154)
- A flaw exists in Single View grade report related to improper capability checks. This may allow an authenticated, remote attacker to edit exclude checkbox in Single View. (CVE-2016-2155)
SolutionUpgrade to Moodle version 3.0.3 or later. If 3.0.x cannot be obtained, versions 2.9.5 or 2.8.11 have also been patched for these issues.