Moodle 2.8.x < 2.8.10 / 2.9.x < 2.9.4 / 3.0.x < 3.0.2 XSS

Medium Nessus Network Monitor Plugin ID 9192


The remote web server is hosting a web application that is vulnerable to a Cross Site Scripting (XSS) attack.


Moodle, an open-source course management system, installed on the remote host is version 2.8.x prior to 2.8.10, or 2.9.x prior to 2.9.4, or 3.0.x prior to 3.0.2, and is affected by a flaw that allows a cross-site scripting (XSS) attack. This flaw exists because the '/moodle/course/management.php' script does not validate the 'search' parameter before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.


Upgrade to Moodle version 3.0.2 or later. If 3.0.x cannot be obtained, versions 2.9.4 or 2.8.10 have also been patched for these issues.

See Also

Plugin Details

Severity: Medium

ID: 9192

Family: CGI

Published: 2016/04/08

Modified: 2016/11/23

Dependencies: 8690, 9398

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 4.9


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2016/01/11

Vulnerability Publication Date: 2016/01/04

Reference Information

CVE: CVE-2016-0725