Moodle 2.8.x < 2.8.9 / 2.9.x < 2.9.3 Distributed DoS

High Nessus Network Monitor Plugin ID 9190

Synopsis

The remote web server is hosting a web application that is vulnerable to a Distributed Denial of Service (DDoS) attack vector.

Description

Moodle, an open-source course management system, installed on the remote host is version 2.8.x prior to 2.8.9, or 2.9.x prior to 2.9.3, and is affected by an unspecified flaw in the editor Autosave feature that is triggered when guest access is open on the site. This may allow a remote attacker to conduct a DDoS attack.

Solution

Upgrade to Moodle version 2.9.3 or later. If version 2.9.x cannot be obtained, version 2.8.9 has also been patched for these issues.

See Also

https://docs.moodle.org/dev/Moodle_2.8.9_release_notes

https://docs.moodle.org/dev/Moodle_2.9.3_release_notes

Plugin Details

Severity: High

ID: 9190

Family: CGI

Published: 2016/04/08

Modified: 2018/09/16

Dependencies: 8690

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2015/11/09

Vulnerability Publication Date: 2015/11/04

Reference Information

CVE: CVE-2015-5332