Moodle 2.9.x < 2.9.3 Security Bypass

Medium Nessus Network Monitor Plugin ID 9189


The remote web server is hosting a web application that is vulnerable to a security bypass attack vector.


Moodle, an open-source course management system, installed on the remote host is version 2.9.x prior to 2.9.3, and is affected by a flaw that is due to the program failing to sufficiently check settings when messaging other users. This may allow an authenticated remote attacker to bypass preferences against receiving mail from non-contacts and send spam mail to a user where it should be blocked.


Upgrade to Moodle version 2.9.3 or later.

See Also

Plugin Details

Severity: Medium

ID: 9189

Family: CGI

Published: 2016/04/08

Modified: 2016/04/08

Dependencies: 8690

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 4.3

Temporal Score: 4


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2015/11/09

Vulnerability Publication Date: 2015/11/05

Reference Information

CVE: CVE-2015-5331