Zend Framework < 1.12.16 SQL Injection

High Nessus Network Monitor Plugin ID 9148

Synopsis

The remote host is using a version of Zend Framework that is vulnerable to SQL Injection (SQLi).

Description

Versions of Zend Framework earlier than 1.12.16 contain a flaw that may allow an SQL injection attack. The issue is due to 'Zend_Db_Adapter_Pdo_Abstract' not properly sanitizing user-supplied input involving null bytes. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.

Solution

Upgrade Zend Framework to version 1.12.16 or later.

See Also

http://framework.zend.com

http://framework.zend.com/security/advisory/ZF2015-08

Plugin Details

Severity: High

ID: 9148

Family: CGI

Published: 2016/03/15

Modified: 2016/03/15

Dependencies: 9135

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2015/09/15

Vulnerability Publication Date: 2015/09/15

Reference Information

CVE: CVE-2015-7695

BID: 76784