Zend Framework < 2.0.1 Multiple XSS

Medium Nessus Network Monitor Plugin ID 9147


The remote host is using a version of Zend Framework that is vulnerable to multiple Cross-Site Scripting (XSS) attack vectors.


Versions of Zend Framework earlier than 2.0.1 are exposed to flaws in the following scripts which allow remote cross-site scripting attacks :

- A flaw exists in the 'Zend\Feed\PubSubHubbub' script. (OSVDB 85683)
- A flaw exists in the 'Zend\Log\Formatter\Xml' script. (OSVDB 85684)
- A flaw exists in the 'Zend\View\Helper\Placeholder\Container\AbstractStandalone' script. (OSVDB 85685)
- A flaw exists in the 'Zend\View\Helper\Navigation\Sitemap' script. (OSVDB 85686)
- A flaw exists in the 'Zend\View\Helper\HeadStyle' script. (OSVDB 85687)
- A flaw exists in the 'Zend\Uri' script. (OSVDB 85688)
- A flaw exists in the 'Zend\Tag\Cloud\Decorator' script. (OSVDB 85689)

The application does not validate certain unspecified input upon submission to these scripts. This may allow a user to create a specially crafted request that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.


Upgrade Zend Framework to version 2.0.1 or later.

See Also




Plugin Details

Severity: Medium

ID: 9147

Family: CGI

Published: 2016/03/15

Modified: 2016/03/15

Dependencies: 9135

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 4.6


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2012/09/20

Vulnerability Publication Date: 2012/09/20

Reference Information

CVE: CVE-2012-4451

BID: 55636