Zend Framework < 2.2.5 Trusted Proxy Bypass

Medium Nessus Network Monitor Plugin ID 9145

Synopsis

The remote host is using a version of Zend Framework that is vulnerable to a security bypass attack.

Description

Versions of Zend Framework prior to 2.2.5 are vulnerable to a flaw in the 'Zend\Http\PhpEnvironment\RemoteAddress' class. The issue is triggered when PHP's $_SERVER['REMOTE_ADDR'] is not taken into account on the trusted proxy server list when handling an incoming proxied request via the 'X-Forwarded-For' header. This may allow a remote attacker to bypass the trusted proxy list.

Solution

Upgrade Zend Framework to version 2.2.5 or later.

See Also

http://framework.zend.com

http://framework.zend.com/changelog/2.2.5

http://framework.zend.com/security/advisory/ZF2013-04

Plugin Details

Severity: Medium

ID: 9145

Family: CGI

Published: 2016/03/15

Modified: 2016/03/15

Dependencies: 9135

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2013/10/31

Vulnerability Publication Date: 2013/11/01

Reference Information

BID: 63486