Zend Framework 1.12.x < 1.12.4 / 2.1.x < 2.1.6 / 2.2.x < 2.2.6 Multiple XEE DoS

high Nessus Network Monitor Plugin ID 9144


The remote host is using a version of Zend Framework that is vulnerable to multiple XEE vulnerabilities.


Versions of Zend Framework 1.12.x earlier than 1.12.4, 2.1.x earlier than 2.1.6, or 2.2.x earlier than 2.2.6 are exposed to XEE (XML Entity Expansion) injection flaws that exist in multiple functions and are triggered during the parsing of XML data via DOCTYPE declarations. The issue is due to an incorrectly configured XML parser accepting XML external entities from an untrusted source. By sending specially crafted XML data, a remote attacker can cause a denial of service.


Upgrade Zend Framework to version 2.2.6 or later. If version 2.2.x is not available, versions 2.1.6 and 1.12.4 are also patched for these vulnerabilities.

See Also



Plugin Details

Severity: High

ID: 9144

Family: CGI

Published: 3/15/2016

Updated: 3/6/2019

Risk Information


Risk Factor: High

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 8.2

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:thomas_breuss:zend_framework_integration_zend_framework:*:*:*:*:*:*:*:*

Patch Publication Date: 3/6/2014

Vulnerability Publication Date: 3/6/2014

Reference Information

CVE: CVE-2014-2681, CVE-2014-2682, CVE-2014-2683, CVE-2014-2052

BID: 66358