Zend Framework < 2.2.7 / 2.3.x < 2.3.1 XSS

Medium Nessus Network Monitor Plugin ID 9143


The remote host is running a version of Zend Framework that is vulnerable to Cross-Site Scripting (XSS) attacks.


Versions of Zend Framework earlier than 2.2.7, or 2.3.x earlier than 2.3.1 are vulnerable to a flaw that allows cross-site scripting (XSS) attacks. This flaw exists because multiple view helpers do not properly validate input to HTML attributes before returning it to users. This may allow an attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.


Upgrade Zend Framework to version 2.3.1 or later. If version 2.3.x is not available, version 2.2.7 is also patched for this vulnerability.

See Also



Plugin Details

Severity: Medium

ID: 9143

Family: CGI

Published: 2016/03/15

Modified: 2016/03/15

Dependencies: 9135

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 4.6


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2014/04/15

Vulnerability Publication Date: 2014/04/15

Reference Information

CVE: CVE-2014-4913

BID: 66971