Zend Framework < 2.2.7 / 2.3.x < 2.3.1 XSS

Medium Nessus Network Monitor Plugin ID 9143

Synopsis

The remote host is running a version of Zend Framework that is vulnerable to Cross-Site Scripting (XSS) attacks.

Description

Versions of Zend Framework earlier than 2.2.7, or 2.3.x earlier than 2.3.1 are vulnerable to a flaw that allows cross-site scripting (XSS) attacks. This flaw exists because multiple view helpers do not properly validate input to HTML attributes before returning it to users. This may allow an attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade Zend Framework to version 2.3.1 or later. If version 2.3.x is not available, version 2.2.7 is also patched for this vulnerability.

See Also

http://framework.zend.com

http://framework.zend.com/changelog/2.3.1

Plugin Details

Severity: Medium

ID: 9143

Family: CGI

Published: 2016/03/15

Modified: 2016/03/15

Dependencies: 9135

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2014/04/15

Vulnerability Publication Date: 2014/04/15

Reference Information

CVE: CVE-2014-4913

BID: 66971