Zend Framework < 1.12.9 / 2.2.x < 2.2.8 / 2.3.x < 2.3.3 SQL Injection

High Nessus Network Monitor Plugin ID 9142

Synopsis

The remote host is using a version of Zend Framework that is vulnerable to SQL Injection (SQLi).

Description

Versions of Zend Framework prior to 1.12.9, 2.2.x earlier than 2.2.8, or 2.3.x earlier than 2.3.3 are vulnerable to a flaw that may allow an SQL injection attack. The issue is due to improper use of the SQLSRV PHP extension, as user-supplied input containing NULL bytes is not properly sanitized. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.

Solution

Upgrade Zend Framework to version 2.3.3 or later. If version 2.3.x is not available, versions 2.2.8 and 1.12.9 are also patched for this vulnerability.

See Also

http://framework.zend.com

http://framework.zend.com/changelog/2.3.3

Plugin Details

Severity: High

ID: 9142

Family: CGI

Published: 2016/03/15

Modified: 2016/03/15

Dependencies: 9135

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2014/09/17

Vulnerability Publication Date: 2014/09/17

Reference Information

CVE: CVE-2014-8089

BID: 70011