Zend Framework < 2.2.10 / 2.3.x < 2.3.5 SQL Injection

High Nessus Network Monitor Plugin ID 9140

Synopsis

The remote host is running a version of Zend Framework that is vulnerable to SQL Injection attacks.

Description

Versions of Zend Framework earlier than 2.2.1, or 2.3.x earlier than 2.3.5 are exposed to a flaw that may allow carrying out an SQL injection attack. The issue is due to the program not properly sanitizing user-supplied input when handling identifiers or values. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.

Solution

Upgrade Zend Framework to version 2.3.5 or later. If version 2.3.x is not available, version 2.2.10 is also patched for this vulnerability.

See Also

http://framework.zend.com

http://framework.zend.com/changelog/2.3.5

Plugin Details

Severity: High

ID: 9140

Family: CGI

Published: 2016/03/15

Modified: 2016/03/15

Dependencies: 9135

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2015/03/12

Vulnerability Publication Date: 2015/03/12

Reference Information

CVE: CVE-2015-0270

BID: 73155