Zend Framework < 2.3.6 CSRF/XSRF

Medium Nessus Network Monitor Plugin ID 9139

Synopsis

The remote host is using a version of Zend Framework that is vulnerable to a Cross-Site Request Forgery (CSRF or XSRF) attack.

Description

Versions of Zend Framework earlier than 2.3.6 are exposed to a flaw in 'Zend\Validator\Csrf' that is triggered as malformed token identifiers are not properly validated. By tricking a user into following a specially crafted link, a context-dependent attacker can bypass the implemented CSRF protection to have the victim perform unspecified actions.

Solution

Upgrade Zend Framework to version 2.3.6 or later.

See Also

http://framework.zend.com

http://framework.zend.com/changelog/2.3.6

Plugin Details

Severity: Medium

ID: 9139

Family: CGI

Published: 2016/03/15

Modified: 2018/09/16

Dependencies: 9135

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2015/03/12

Vulnerability Publication Date: 2015/03/12

Reference Information

CVE: CVE-2015-1786

BID: 73157