Zend Framework < 2.4.9 Encryption Weakness

Medium Nessus Network Monitor Plugin ID 9137

Synopsis

The remote host is using a version of Zend Framework that is vulnerable to a chosen-ciphertext attack vector.

Description

Versions of Zend Framework earlier than 2.4.9 are exposed to a flaw in 'zend-crypt' that is triggered when 'Zend\Crypt\PublicKey\Rsa\PublicKey' contains a call to 'openssl_public_encrypt()' that ultimately uses PKCS1v1.5 padding. This padding has a known vulnerability, known as Bleichenbacher's chosen-ciphertext attack, which can be used to recover an RSA private key. This may potentially allow a remote attacker to decrypt ciphertext.

Solution

Upgrade Zend Framework to version 2.4.9 or later.

See Also

http://framework.zend.com

http://framework.zend.com/changelog/2.4.9

http://framework.zend.com/security/advisory/ZF2015-10

http://blog.cryptographyengineering.com/2016/03/attack-of-week-drown.html

Plugin Details

Severity: Medium

ID: 9137

Family: CGI

Published: 2016/03/15

Modified: 2016/03/15

Dependencies: 9135

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2015/11/23

Vulnerability Publication Date: 2015/11/23

Reference Information

CVE: CVE-2015-7503

BID: 77688