Zend Framework 1.x < 1.12.14 / 2.x < 2.4.6 / 2.5.x < 2.5.2 XXE Injection

High Nessus Network Monitor Plugin ID 9136


The remote host is using a version of Zend Framework that is vulnerable to an XXE (Xml eXternal Entity) injection attack.


Versions of Zend Framework 1.x earlier than 1.12.14, 2.x earlier than 2.4.6, or 2.5.x earlier than 2.5.28 are vulnerable to an XXE (Xml eXternal Entity) injection flaw in ZendMXL that is triggered during the parsing of multibyte XML data. The issue is due to an incorrectly configured XML parser accepting XML external entities from an untrusted source. By sending specially crafted XML data, a remote attacker can gain unauthorized access to information or cause a denial of service.


Upgrade Zend Framework to version 2.5.2 or later. If version 2.5.x is not available, versions 2.4.6 and 1.12.14 are also patched for these vulnerabilities.

See Also



Plugin Details

Severity: High

ID: 9136

Family: CGI

Published: 2016/03/15

Modified: 2016/03/15

Dependencies: 9135

Risk Information

Risk Factor: High


Base Score: 8.5

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 8.2

Temporal Score: 7.6


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2015/08/03

Vulnerability Publication Date: 2015/08/03

Reference Information

CVE: CVE-2015-5161

BID: 76177