MyBB < 1.6.17 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9123

Synopsis

The remote web server is running a PHP application that is vulnerable to multiple attack vectors.

Description

Versions of MyBB (MyBulletinBoard) prior to 1.6.17 are affected by the following vulnerabilities :

- Multiple unspecified flaws exist that allow stored cross-site scripting (XSS) attacks. These flaws exist because the program does not validate input before returning it to users. This may allow an authenticated remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 122742)
- A flaw in ACP login as HTTP requests do not require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. By tricking a user into following a specially crafted link, a context-dependent attacker can perform a Cross-Site Request Forgery (CSRF / XSRF) attack causing the victim to perform unspecified actions. (OSVDB 122743)
- A flaw exists that is due to the cache handler using 'var_export' without encoding checks. This may allow an attacker to have an unspecified impact. (OSVDB 122744)

Solution

Upgrade to MyBB version 1.6.17 or later.

See Also

http://www.nessus.org/u?371868c4

http://docs.mybb.com/versions/1.6.17

Plugin Details

Severity: High

ID: 9123

Family: CGI

Published: 2016/03/03

Modified: 2016/11/23

Dependencies: 9125

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mybb:mybb

Patch Publication Date: 2015/05/27

Vulnerability Publication Date: 2015/05/27