MyBB 1.8.x < 1.8.5 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9122

Synopsis

The remote web server is running a PHP application that is vulnerable to multiple attack vectors.

Description

Versions of MyBB (MyBulletinBoard) prior to 1.6.17, or 1.8.x prior to 1.8.5 are affected by the following vulnerabilities :

- A flaw exists that allows a stored cross-site scripting (XSS) attack. This flaw exists because the quick edit function in the '/xmlhttp.php' script does not validate input before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists that is triggered when sending an email to a user in 'member.php'. This flaw may allow a remote attacker to spoof the sender of the email.

Solution

Upgrade to MyBB version 1.8.5 or later.

See Also

http://www.nessus.org/u?371868c4

http://docs.mybb.com/versions/1.8.5

Plugin Details

Severity: Medium

ID: 9122

Family: CGI

Published: 2016/03/03

Modified: 2018/09/16

Dependencies: 9125

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mybb:mybb

Patch Publication Date: 2015/05/27

Vulnerability Publication Date: 2015/05/27