MyBB < 1.6.15 XSS

Medium Nessus Network Monitor Plugin ID 9120


The remote web server is running a PHP application that is vulnerable to a cross-site scripting (XSS) attack.


Versions of MyBB (MyBulletinBoard) prior to 1.6.15 are affected by a cross-site scripting vulnerability. Specifically, the flaw affects 'video MyCode' and exists because the program does not validate input before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.


Upgrade to MyBB version 1.6.15 or later.

See Also

Plugin Details

Severity: Medium

ID: 9120

Family: CGI

Published: 2016/03/03

Modified: 2016/12/12

Dependencies: 9125

Nessus ID: 81699

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 3.6

Temporal Score: 3.3


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mybb:mybb

Patch Publication Date: 2014/08/04

Vulnerability Publication Date: 2014/08/04

Reference Information

CVE: CVE-2014-5248