phpMyAdmin 4.4.x < / 4.5.x < 4.5.1 Content Spoofing Vulnerability (PMASA-2015-5)

Medium Nessus Network Monitor Plugin ID 9118


The remote web server contains a PHP application that is affected by a content spoofing vulnerability.


Versions of phpMyAdmin 4.4.x prior to, or 4.5.x prior to 4.5.1 are unpatched for a flaw in the redirection mechanism that is triggered as input passed via the 'url' parameter is not properly sanitized in the 'url.php' script. This may allow a context-dependent attacker to inject arbitrary content.


Upgrade to phpMyAdmin / 4.5.1 or later. Alternatively, apply the patch referenced in the vendor advisory.

See Also

Plugin Details

Severity: Medium

ID: 9118

Family: CGI

Published: 2016/03/02

Modified: 2016/03/02

Dependencies: 9102

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 5.3

Temporal Score: 4.9


Temporal Vector: CVSS3#E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2015/10/23

Vulnerability Publication Date: 2015/10/20

Reference Information

CVE: CVE-2015-7873

BID: 77299