phpMyAdmin 4.5.x < 4.5.4 Multiple Vulnerabilities (PMASA-2016-8, PMASA-2016-9)

Medium Nessus Network Monitor Plugin ID 9117

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin 4.5.x prior to 4.5.4 are unpatched for the following vulnerabilities :

- An information disclosure vulnerability exists in multiple scripts that allow a remote attacker, via a specially crafted request, to disclose the software's installation path. (CVE-2016-2044)
- A cross-site scripting (XSS) vulnerability exists due to improper validation of user-supplied input to the SQL editor. An authenticated, remote attacker can exploit this, via a specially crafted SQL query, to execute arbitrary script code in a user's browser session. (CVE-2016-2045)

Solution

Upgrade to phpMyAdmin 4.5.4 or later. Alternatively, apply the patch referenced in the vendor advisory.

See Also

https://www.phpmyadmin.net/security

https://www.phpmyadmin.net/security/PMASA-2016-8

https://www.phpmyadmin.net/security/PMASA-2016-9

Plugin Details

Severity: Medium

ID: 9117

Family: CGI

Published: 2016/03/02

Modified: 2018/09/16

Dependencies: 9102

Nessus ID: 88987

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 4.2

Temporal Score: 4

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2016/01/23

Vulnerability Publication Date: 2016/01/23

Reference Information

CVE: CVE-2016-2044, CVE-2016-2045

BID: 82100, 82104