WordPress < 3.1.1 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9113


The remote server is hosting an outdated installation of WordPress that is vulnerable to multiple attack vectors.


Versions of WordPress prior to 3.1.1 are susceptible to the following vulnerabilities :

- A flaw exists that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate certain unspecified input before returning it to the user. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server. (CVE-2011-4956)
- A flaw exists that may allow a remote denial of service. The issue is triggered when the 'make_clickable()' function in the 'wp-includes/formatting.php' script fails to properly verify URL length in comments before passing it to the PCRE library, resulting in a loss of availability. (CVE-2011-4957)


Upgrade to WordPress 3.1.1, or later.

See Also



Plugin Details

Severity: Medium

ID: 9113

Family: CGI

Published: 2016/02/26

Modified: 2016/02/26

Dependencies: 9035, 9036

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Patch Publication Date: 2011/04/05

Vulnerability Publication Date: 2011/04/05

Reference Information

CVE: CVE-2011-4956, CVE-2011-4957

BID: 47187