WordPress < 3.0.1 Privilege Escalation Vulnerability

Medium Nessus Network Monitor Plugin ID 9111

Synopsis

The remote server is hosting an outdated installation of WordPress that is vulnerable to a privilege escalation attack.

Description

Versions of WordPress prior to 3.0.1 are susceptible to a flaw when multisite installations are used that is due to the program retaining the 'site administrators can add users' option when it was changed. This may allow a remote authenticated attacker to add a user after a change to that setting and bypass intended access restrictions.

Solution

Upgrade to WordPress 3.0.1, or later.

See Also

http://codex.wordpress.org/Changelog/3.0.1

https://core.trac.wordpress.org/ticket/14119

Plugin Details

Severity: Medium

ID: 9111

Family: CGI

Published: 2016/02/26

Modified: 2018/09/16

Dependencies: 9035, 9036

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 3.5

Temporal Score: 3.3

Vector: CVSS3#AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Patch Publication Date: 2010/06/27

Vulnerability Publication Date: 2010/06/27

Reference Information

CVE: CVE-2010-5297

BID: 65234