phpMyAdmin 4.3.x < 4.3.13.2 / 4.4.x < 4.4.14.1 reCaptcha Bypass (PMASA-2015-4)

Medium Nessus Network Monitor Plugin ID 9105

Synopsis

The remote web server contains a PHP application that is affected by a captcha bypass vulnerability.

Description

Versions of phpMyAdmin 4.3.x prior to 4.3.13.2 or 4.4.x prior to 4.4.14.1 are unpatched for by a security bypass vulnerability related to reCaptcha processing. An unauthenticated, remote attacker can exploit this to bypass the reCaptcha test, resulting in a bypass of brute-force protection.

Solution

Upgrade to phpMyAdmin 4.3.13.2 / 4.4.14.1 or later. Alternatively, apply the patch referenced in the vendor advisory.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2015-4.php

http://www.nessus.org/u?24135dd6

http://www.nessus.org/u?b092eb7e

Plugin Details

Severity: Medium

ID: 9105

Family: CGI

Published: 2016/02/25

Modified: 2018/09/16

Dependencies: 9102

Nessus ID: 85986

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2015/09/08

Vulnerability Publication Date: 2015/09/08

Reference Information

CVE: CVE-2015-6830