WordPress < 3.4.2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9099

Synopsis

The remote server is hosting an outdated installation of WordPress that is vulnerable to multiple attack vectors.

Description

Versions of WordPress prior to 3.4.2 are susceptible to the following vulnerabilities :

- A flaw exists that is triggered when the 'create_post' function in the 'wp-includes/class-wp-atom-server.php' script fails to properly check for compatibility when creating new posts. This may allow a remote attacker to create a new post via the AtomPub feature. (CVE-2012-4421)
- A flaw exists that is triggered when the 'wp-admin/plugins.php' scripts fails to enforce network-administrator privileges before activating a plugin across a network. This may allow a remote authenticated attacker to make unintended changes to a plugin. (CVE-2012-4422)

Solution

Upgrade to WordPress 3.4.2, or later.

See Also

http://codex.wordpress.org/Version_3.4.2

https://wordpress.org/news/2012/09/wordpress-3-4-2

Plugin Details

Severity: Medium

ID: 9099

Family: CGI

Published: 2016/02/26

Modified: 2018/09/16

Dependencies: 9035, 9036

Nessus ID: 62046

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 4.3

Temporal Score: 4.1

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Patch Publication Date: 2012/06/27

Vulnerability Publication Date: 2012/06/27

Reference Information

CVE: CVE-2012-4421, CVE-2012-4422

BID: 55455