WordPress < 3.5 CSRF/XSRF Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9098


The remote server is hosting an outdated installation of WordPress that is vulnerable to Cross Site Request Forgery attacks.


Versions of WordPress prior to 3.5 are susceptible to a flaw that allows a remote Cross-site Request Forgery (CSRF / XSRF) attack. The flaw exists because the application does not require multiple steps or explicit confirmation for sensitive transactions. By using a crafted URL (e.g., a crafted GET request inside an "img" tag), an attacker may trick the victim into clicking on the image to take advantage of the trust relationship between the authenticated victim and the application. Such an attack could trick the victim into changing the URL of the feed for the incoming links section in the context of their session with the application, without further prompting or verification.


Upgrade to WordPress 3.5, or later.

See Also


Plugin Details

Severity: Medium

ID: 9098

File Name: 9098.prm

Family: CGI

Published: 2016/02/26

Modified: 2016/11/23

Dependencies: 9035, 9036

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 6.3

Temporal Score: 5.9


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Patch Publication Date: 2013/09/11

Vulnerability Publication Date: 2013/09/11

Reference Information

CVE: CVE-2012-4448

BID: 55795