Apache Solr 5.3.x < 5.3.2 Authentication Bypass

Medium Nessus Network Monitor Plugin ID 9073

Synopsis

The remote web server contains a Java application that is affected by an authentication bypass vulnerability.

Description

Versions of Apache Solr 5.3.x prior to 5.3.2 are affected by a authentication bypass flaw. This flaw exists due to the basic auth plugin failing to enforce credential requirements for authentication mechanisms. This may allow a remote attacker to bypass intended restrictions on the unauthenticated execution of certain actions. (OSVDB 131883)

Solution

Upgrade to Solr 5.4.0 or later. If 5.4.x cannot be obtained, 5.3.2 has also been patched for this vulnerability.

See Also

http://lucene.apache.org/solr/5_4_0/changes

https://issues.apache.org/jira/browse/SOLR-8167

https://issues.apache.org/jira/browse/SOLR-8408

https://issues.apache.org/jira/browse/SOLR-8439

Plugin Details

Severity: Medium

ID: 9073

Family: CGI

Published: 2016/02/05

Modified: 2016/02/19

Dependencies: 8967

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:solr

Patch Publication Date: 2015/12/14

Vulnerability Publication Date: 2015/12/11