WordPress < 4.4.1 XSS

Medium Nessus Network Monitor Plugin ID 9065

Synopsis

The remote server is hosting an outdated installation of WordPress that is vulnerable to a cross-site scripting (XSS) attack.

Description

Versions of WordPress prior to 4.3.1 are susceptible to a flaw that allows a cross-site scripting (XSS) attack. This flaw exists because the 'wp-includes/class-wp-theme.php' script does not validate input before returning it to users in error messages. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (CVE-2016-1564)

Solution

Upgrade to WordPress 4.4.1, or later.

See Also

https://wordpress.org/news/2016/01/wordpress-4-4-1-security-and-maintenance-release

Plugin Details

Severity: Medium

ID: 9065

Family: CGI

Published: 2016/01/29

Modified: 2016/11/23

Dependencies: 9035, 9036

Nessus ID: 87921

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.8

Temporal Score: 5.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2016/01/06

Vulnerability Publication Date: 2016/01/06

Reference Information

CVE: CVE-2016-1564

BID: 76744, 76745, 76748, 79914