OpenSSH 5.4 <= 7.1p1 Roaming Connection Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9055


The remote SSH client may be affected by multiple vulnerabilities.


Versions of OpenSSH starting with 5.4 until 7.1p1 contain some flaws in the undocumented roaming feature. Version 7.1p2 has been released to address the following client side vulnerabilities :

- Using a specially crafted SSH server, a context-dependent attacker can disclose sensitive memory contents when the client authenticates to the server, such as the client's private SSH keys. (CVE-2016-0777)
- An unspecified overflow condition exists that is triggered as user-supplied input is not properly validated. With a specially crafted SSH server, a context-dependent attacker can cause a buffer overflow, potentially allowing the execution of arbitrary code. (CVE-2016-0778)

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.


Upgrade to OpenSSH version 7.1p2 or later. Alternatively, adding the undocumented option "UseRoaming no" to the system-wide configuration file will eliminate these vulnerabilities.

See Also

Plugin Details

Severity: Medium

ID: 9055

Family: SSH

Published: 2016/01/15

Modified: 2016/11/23

Dependencies: 1968

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.6

Temporal Score: 5.4


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Patch Publication Date: 2016/01/14

Vulnerability Publication Date: 2016/01/14

Reference Information

CVE: CVE-2016-0777, CVE-2016-0778