WordPress < 4.3.1 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9032

Synopsis

The remote server is hosting an outdated installation of WordPress that is vulnerable to multiple attack vectors.

Description

Versions of WordPress prior to 4.3.1 are susceptible to the following vulnerabilities :

- A cross-site scripting vulnerability exists when processing shortcode tags due to improper validation of user-supplied input. An attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2015-5714)
- A cross-site scripting (XSS) vulnerability affects the User List. This flaw exists because the program does not validate input to user list tables before returning it to users. (CVE-2015-7989)
- An unspecified vulnerability exists that allows an authenticated attacker to publish private posts and make them 'sticky'. (CVE-2015-5715)

Solution

Upgrade to WordPress 4.3.1, or later.

See Also

http://codex.wordpress.org/Version_4.3.1

https://wordpress.org/news/2015/09/wordpress-4-3-1

http://www.nessus.org/u?edee75c9

Plugin Details

Severity: Medium

ID: 9032

Family: CGI

Published: 2015/12/17

Modified: 2016/01/29

Dependencies: 9035, 9036

Nessus ID: 85985

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 4

Temporal Score: 3.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2015/09/15

Vulnerability Publication Date: 2015/09/15

Reference Information

CVE: CVE-2015-5714, CVE-2015-5715, CVE-2015-7989

BID: 76744, 76745, 76748

IAVA: 2015-A-0219