WordPress < 3.9.5 / 4.1.x < 4.1.4 / 4.2.x < 4.2.1 Comments Stored XSS

Medium Nessus Network Monitor Plugin ID 9027

Synopsis

The remote server is hosting an outdated installation of WordPress that is affected by a cross-site scripting vulnerability.

Description

Versions of WordPress 3.9.x prior to 3.9.5 , 4.1.x prior to 4.1.4 , and 4.2.x prior to 4.2.1 are affected by an input validation flaw that allows an unauthenticated attacker to inject JavaScript into WordPress comments. This could result in a stored cross-site scripting attack being carried out when the affected comment is later viewed.

Solution

Upgrade to WordPress 4.2.1, or later. If 4.2.x cannot be obtained, 4.1.4 was also patched for this vulnerability.\n\nAs a workaround, disable comments and do not approve any comments.

See Also

http://codex.wordpress.org/Version_4.2.1

http://codex.wordpress.org/Version_4.1.4

http://seclists.org/fulldisclosure/2015/Apr/84

http://klikki.fi/adv/wordpress2.html

Plugin Details

Severity: Medium

ID: 9027

Family: CGI

Published: 2015/12/17

Modified: 2016/11/23

Dependencies: 9035, 9036

Nessus ID: 83138

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 4

Temporal Score: 3.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2015/04/27

Vulnerability Publication Date: 2015/04/26

Reference Information

BID: 74334