Apache Solr < 5.3.1 XSS

Medium Nessus Network Monitor Plugin ID 8990

Synopsis

The remote web server contains a Java application that is affected by a persistent cross-site scripting (XSS) vulnerability.

Description

Versions of Apache Solr prior to 5.3.1 are affected by a persistent cross-site scripting vulnerability. Specifically, this flaw exists because the Admin UI stats page does not validate input before returning it to users. A remote, unauthenticated attacker can exploit this issue to execute arbitrary JavaScript within the context of a victim's browser, allowing the attacker to steal session information, log key strokes, and perform other malicious attacks.

Solution

Upgrade to Solr 5.3.1 or later.

See Also

http://lucene.apache.org/solr/5_3_1/changes/Changes.html

https://issues.apache.org/jira/browse/SOLR-7949

Plugin Details

Severity: Medium

ID: 8990

Family: CGI

Published: 2015/10/15

Modified: 2016/02/19

Dependencies: 8967

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:solr

Patch Publication Date: 2015/09/24

Vulnerability Publication Date: 2015/09/24