Apache Solr < 5.1 Multiple XSS

Medium Nessus Network Monitor Plugin ID 8975

Synopsis

The remote web server contains a Java application that is affected by multiple persistent cross-site scripting (XSS) vulnerabilities.

Description

Versions of Apache Solr prior to 5.1 are affected by two persistent cross-site scripting vulnerabilities. Specifically, these affect the Schema-Browser page and Analysis page due to a failure to sanitize field names used in queries before returning them to the user of the Solr administration panel. A remote, unauthenticated attacker can exploit this issue to execute arbitrary JavaScript within the context of a victim's browser, allowing the attacker to steal session information, log key strokes, and perform other malicious attacks.

Solution

Upgrade to Solr 5.1 or later.

See Also

http://lucene.apache.org/solr/5_1_0/changes/Changes.html

https://issues.apache.org/jira/browse/SOLR-7346

Plugin Details

Severity: Medium

ID: 8975

Family: CGI

Published: 2015/10/15

Modified: 2016/02/19

Dependencies: 8967

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:solr

Patch Publication Date: 2015/04/03

Vulnerability Publication Date: 2015/04/03